Ubuntu 10.10 x86_64 on your Dell E6410 with NVS 3100m GPU 2


Well howdy hoo! This is the fastest and most painless guide to installing Ubuntu 10.10 (Maverick Meerkat) x86_64 on your Dell E6410 laptop with NVS 3100m GPU.

More specifically, installing Ubuntu 10.10 on this specific hardware configuration poses two problems:

  1. Blank (black, no backlight) display when booting with the install media, or, if you manage to get Linux on the machine, with the installation itself.
  2. Blank (black, no backlight) display when resuming from suspend to ram after having installed Ubuntu.

Solving problem 1

  • Boot with the normal Ubuntu 10.10 x86_64 Desktop live disc. I usually do this from USB memory.
  • When you get to the first boot menu (“Try Ubuntu without installing”, “Install Ubuntu”, etc.), press F6 for other options, then ESC to kill the menu that appears. Move the menubar to “Try Ubuntu without installing”.
  • You can now edit the boot command-line. Replace “quiet splash” with “nouveau.modeset=0″
  • Press enter to boot into the live desktop, then install the whole business as per usual.
  • At the first boot after installation, press ‘e’ at the grub boot screen to edit the command line and again replace “splash quiet” with “nouveau.modeset=0″.
  • You should get all the way to the Ubuntu desktop.
  • Activate the NVidia drivers via System | Administration | Additional Drivers
  • Now edit /etc/default/grub, and replace “splash quiet” in the GRUB_CMDLINE_LINUX_DEFAULT with, you guessed it, “nouveau.modeset=0″.
  • Run “sudo update-grub” at the command-line.
  • Problem solved.

Solving problem 2

  • Edit the GRUB_CMDLINE_LINUX_DEFAULT variable¬†/etc/default/grub again. When you’re done, it should read (we’ve added the acpi_sleep bit at the end):
    GRUB_CMDLINE_LINUX_DEFAULT="nouveau.modeset=0 acpi_sleep=nonvs"
  • Run “sudo update-grub” at the command-line.
  • Problem solved.
  • (if you really want to know more about this, including several other more painful work-arounds, read this bug report)

Generally, I’m really impressed with the general slickness of 10.10 on this machine. What impressed me particularly, was that powertop reported about 14W of power consumption at idle on this out-of-the-box setup (disregarding the two tweaks above). It used to take much more effort to get that low.


Leave a Comment

Your email address will not be published. Required fields are marked *

You may use these HTML tags and attributes: <a href="" title=""> <abbr title=""> <acronym title=""> <b> <blockquote cite=""> <cite> <code> <del datetime=""> <em> <i> <q cite=""> <strike> <strong>

2 thoughts on “Ubuntu 10.10 x86_64 on your Dell E6410 with NVS 3100m GPU